Connecting Link Problem

  1. Welcome to 6x6 World.

    You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

    If you have any problems with the registration process or your account login, please contact us. Looking forward to seeing you in the forums and talking about AATVs!
+ Reply to Thread
Results 1 to 4 of 4

Thread: Connecting Link Problem

Hybrid View

  1. #1
    Join Date
    Dec 2009
    Location
    Newfoundland, Canada
    Posts
    71

    Connecting Link Problem

    I need a connecting link for my rear RC60 chain for my 2009 Argo Avenger. Neither one of the dealers in the area have it in stock. A week to ten days to order it in. It is the type that has a clip … which is not in stock either. I have a connecting link from an old RC60 idler chain that I replaced some years ago. It is not the same type as it has two tiny (2mm) cotter pins instead of the clip. Can I use that in a pinch until I can get the other type ordered in?
    Last edited by Zircon; 02-03-2024 at 03:18 PM.

  2. #2
    Join Date
    Feb 2013
    Location
    shenendoah valley,va.
    Posts
    2,646
    not sure what RC stands for ? different than regular or heavy duty # 60 ? jboy va

  3. #3
    Join Date
    May 2010
    Location
    Fairbanks AK
    Posts
    1,457
    Cotter pin links will work fine.

  4. #4
    Join Date
    Dec 2009
    Location
    Newfoundland, Canada
    Posts
    71
    Thanks for replying, msafi65!

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts