Beyond Frustrated with my Mikuni Carb - May go to Tillotson

  1. Welcome to 6x6 World.

    You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

    If you have any problems with the registration process or your account login, please contact us. Looking forward to seeing you in the forums and talking about AATVs!
+ Reply to Thread
Results 1 to 3 of 3

Thread: Beyond Frustrated with my Mikuni Carb - May go to Tillotson

  1. #1
    Join Date
    Sep 2012
    Location
    Dillsburg, PA
    Posts
    104

    Beyond Frustrated with my Mikuni Carb - May go to Tillotson

    Hi Everyone. I wanted to see if anyone has used a Tillotson carb on a JLO 400 in and Attex? My JLO has a Mikuni carb on it - as per the factory and it leaks (not sure from where). I replaced the intake, and got another carb and still the same thing. Replaced the fuel pump twice and all of the lines are new. It also seems to starve for fuel some times and other times it floods. Both carbs were rebuilt a few times with different parts - the latest being genuine Mikuni - no difference. Float level is correct and I even bought new floats. I have a ultrasonic cleaner and both carbs were cleaned using this - they are spottless. I have rebuilt and used Mikuni's for 30+ years and loved them, but not in this Attex.

    So anyways, I am done with these Mikunis and I have a JLO with a Tillotson car and intake on it. I am considering swapping it and removing the external Mikuni fuel pump. I assume this is from a snowmobile so will have have jetting issues? Also, there is no insulator between the intake and carb - will I have vapor lock issues? Thank you!

  2. #2
    Join Date
    Jan 2014
    Location
    clifton IL
    Posts
    809
    I have had the same issues with a mikuni carb myself. I put new needle and seat and such. Still flooded the engine and carb. Put a new mikuni pump on it and my issue went away!! I can't answer it but that is what fixed it and I haven't had an issue since. As far as the tillotsons go I've never been able to make one run good using one.
    Good luck whichever way you go.

  3. #3
    Join Date
    Sep 2012
    Location
    Dillsburg, PA
    Posts
    104
    Thanks. Yes I think I saw your post and that made me try a new fuel pump but no luck...

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts